Ulrich T

Ersatz der Festplatte im Navi - SSD, CF - wer hat es erfolgreich getan?

Recommended Posts

alfredschmitz

Hallo C6-Fahrer!

 

Hat inzwischen jemand die Festplatte erfolgreich durch eine CF-Karte ersetzt?

Würde mich über positive Rückmeldungen freuen.

 

Gruß

Alfred

Link zum Beitrag


Link zum Beitrag
Auf anderen Seiten teilen
accmzöbix
Am 1.2.2016 at 14:20 , alfredschmitz sagte:

Hat inzwischen jemand die Festplatte erfolgreich durch eine CF-Karte ersetzt?

Würde mich über positive Rückmeldungen freuen.

Hab ich heute  abend gemacht, und zwar exakt! nach NG4 Anleitung  im hiesisgen Forum mit ident  Material :

PKW: C6 170 pallas Navi, Schalt, Bj 2007, mit Magneti Marelli  RT3 X6-N3 (Läuft als  "RT4") mit 30 GB Hitatchi Festpaltte.

Zerlegen des Gerätes + Ausbau mit  langem Torx 10.

Nach Ausbau des RT3/4: entfernen der 4 Tx10 Eckschrauben und abnehmen des CD-Laufwerkes (ist nur draufgelegt und hakt  am li Rand etwas) Darunter ist die  Festplatte in einer Plastikwanne  an den 4 Ecken  eingeklipst.

Datenübertragung  wie in Anleitung (Kopieren  dauert ca  2x 25 Min)

 

Ob es funktioniert  hat  schreibe ich sobald es wieder Tag geworden ist.

  • Like 1

Link zum Beitrag


Link zum Beitrag
Auf anderen Seiten teilen
accmzöbix

"Ob es funktioniert  hat  schreibe ich sobald es wieder Tag geworden ist. "

 

Nu is es  Tag geworden und: --  es hat  nicht ! funktioniert.

Citroen Logo erscheint, dann  dunkler  Schirm und erneuter Startversuch nach ca 30 sec. . Unabh ob die  CF Karte  als Master oder als Save  gejumpert ist.

also  HDD  wieder  rein , und alles  ist  beim Alten.

Hab grad keine  Idee, wir man es hinbekommen kann.

Link zum Beitrag


Link zum Beitrag
Auf anderen Seiten teilen
alfredschmitz

Danke accmzöbix,

Deine Erfahrung hat mich vor unnötigen Ausgaben bewahrt.

Ich hatte allerdings vor 2 Jahren bei mir beim Magneti Marelli  RT3 X6-N3 (Läuft als  "RT4") mit 30 GB Hitatchi Festplatte die Originalfestplatte getauscht, da sie etwas schwächelte. Das hat durch Clonen der Originalfestplatte einwandfrei funktioniert.

Schade, dass es mit der CF-Karte nicht klappen will.

Link zum Beitrag


Link zum Beitrag
Auf anderen Seiten teilen
Chaotec

Das ist ja komisch. Mit dem RT4 kenne ich mich nicht so gut aus, evtl kann das System nicht mit Festplatten/Karten größer 40GB umgehen.

Link zum Beitrag


Link zum Beitrag
Auf anderen Seiten teilen
accmzöbix

Alle 4 Partitionen  mit Dateien sind korrekt  auf die CF-Karte  kopiert worden. Ob mit Inhalt  und was da drin steht entzieht sich bislang meiner Kenntnis.

Link zum Beitrag


Link zum Beitrag
Auf anderen Seiten teilen
accmzöbix
vor 2 Stunden, Chaotec sagte:

Das ist ja komisch. Mit dem RT4 kenne ich mich nicht so gut aus, evtl kann das System nicht mit Festplatten/Karten größer 40GB umgehen.

Hab in einem französichen Forum gefunden:  Ersatz der  HDD gegen eine 128!! GB SSD und funktioniert wohl (4 Jumper-Pins auch abgesägt)

http://www.planete-citroen.com/forum/showthread.php?t=136087&page=9

- sollte also nicht an der Speichergröße liegen. In disem Forum  wird  kräftig mit "Acronis" geklont, evtl liegts daran ??

 

Link zum Beitrag


Link zum Beitrag
Auf anderen Seiten teilen
Chaotec

Also CF Karte / SSD ist technisch gesehen das Gleiche. Eine CF Karte entspricht elektrisch sogar noch eher einer normalen Festplatte, als eine SSD.

Man kann das mit "Acronis" auf jeden Fall mal testen. Das Programm, was in meiner Anleitung steht kopiert "raw". Das bedeutet, es kopiert einfach Sektor für Sektor, egal was auf der Platte drauf ist. Genauer kann man eigentlich nicht kopieren, aber irgendwo muss es ja hängen, sonst würde die ja im RT4 funktionieren.

Link zum Beitrag


Link zum Beitrag
Auf anderen Seiten teilen
accmzöbix

Grübel! - könnte  es daran liegen, daß beim Kopiervorgang! der CF-Adapter  gemastert war? (Einbau dann als slave!)  Kopieren lief problemlos,  Partitionen sind auf CF. Playlist ist auch da,  jedoch  nicht leer Musik über Mediaplayer abspielbar).

bearbeitet von accmzöbix

Link zum Beitrag


Link zum Beitrag
Auf anderen Seiten teilen
Chaotec

Nee eigentlich kann es nicht daran liegen. Der Master/Slave Schalter ist ja nur ne physikalische Brücke. Das ändert an den Daten auf der Platte nichts.

Ich habe mich gerade mal durch ein französisches Forum gelesen. Es kann sein, dass beim Kopiervorgang was schief gelaufen ist bzw die "Spenderplatte" schon einige kleine Fehler hatte. Es soll wohl helfen, wenn man mit der Update CD von Citroen das System nochmal updaten lässt, da dadurch alle wichtigen Dateien neu geschrieben werden (Die Einstellungen bleiben erhalten).

Link zum Beitrag


Link zum Beitrag
Auf anderen Seiten teilen
accmzöbix

H E U R E K A !!

Nu hab ich eben  einfach nochmals  die HDD ausgebaut und die bespielte (nach Anleitung kopierte) CF-Karte  eingesteckt und  siehe da, alles  funktionierte (Radio, juke-Box und Navigation - Rest nicht geprüft).  Vielleicht war es ein Kontaktproblem  oä was beim ersten  Versuch den Erfolg vereitelt hat.

Also: Magneti Marelli  RT3 X6-N3 (Läuft als  "RT4") mit 30 GB Hitachi Festplatte ist nach  Anleitung  v "Chatoec" mit einer 64GB-CF-Karte betreibbar.

An dieser Stelle  ein herzliches  Dankeschön an  "Chaotec"

Sollte die CF nicht meht  funktionieren, so habe ich noch die HDD und  wenn die  auch kaputt ist, dann habe ich ja immer noch eine  Flasche  Chantré.

 

  • Like 1

Link zum Beitrag


Link zum Beitrag
Auf anderen Seiten teilen
Ulrich T

@ Chaotc und zöbix: Euch beiden Pionieren schon mal besten Dank! Sowie mein C6 aus dem Winterschlaf geweckt wird, werde ich mich, Eurem Beispiel folgend, heranwagen. 

Link zum Beitrag


Link zum Beitrag
Auf anderen Seiten teilen
alfredschmitz

Das ist ja wunderbar. Dann werde ich mich in die Reihe der CF-Karten-Einbauer einreihen!

Vielen Dank für eure Erfahrungsmeldungen.

 

Alfred

Link zum Beitrag


Link zum Beitrag
Auf anderen Seiten teilen
accmzöbix
Am 5.2.2016 at 16:28 , accmzöbix sagte:

 

----- Schwierige  Menüführung hier ----

Also ! : Hab nun auch das Navi des  zweiten  Familiencitroen von Festplatte  auf   CF-Karte umgerüstet. Es gab  überhaupt kein Problem wenn man nach Anleitung v "Chaotec" vorgeht.

Somit läuft nun das Navi : "RT3 eV-N3-Q2" mit 30GB Toshiba HDD  (keine 3D-Animation) in einem  C5II  HD170 excl. Aut. BJ 2007 problemlos mit CF.

Grüße

 

bearbeitet von accmzöbix

Link zum Beitrag


Link zum Beitrag
Auf anderen Seiten teilen
Chaotec

Ich hätte Geld für die Anleitung nehmen sollen :lol:

Link zum Beitrag


Link zum Beitrag
Auf anderen Seiten teilen
Daimlervernichter

Hallo Chaotec

kannst es ja auf EBay für faule oder nicht so versierte Angsthasen anbieten. :-p

Gruß Haiko

Gesendet von iPhone mit Tapatalk

Link zum Beitrag


Link zum Beitrag
Auf anderen Seiten teilen
Chaotec

Könnte ich. Ich hab sogar nen Gewerbeschein (den ich drigend mal abmelden müsste)...zum Glück bin ich nicht auf zusätzliche Einnahmequellen angewiesen und bekäme das zeitlich auch nur schlecht hin.

Wer ganz doll Angst hat, kann sich trotzdem bei mir melden. Da würde ich dann gegen Erstattung der Porto bzw Spritkosten helfen :)

Link zum Beitrag


Link zum Beitrag
Auf anderen Seiten teilen
-Hida0815

Moin Zusammen,

habe einmal meinen Post aus dem Schwesterforum hier reinkopiert, falls der noch nicht bekannt war. Nach einem Jahr kann ich sagen, dass die SSD immer noch prima in meinem RT4 läuft (C5 II HDI170 BJ2007). 

------------------------------------------

Moin,
habe erfolgreich die kränkelnde HDD meines RT4 durch eine SSD ersetzt.
Es gibt ja bereits diverse Beiträge hierzu, jedoch habe ich noch nichts Komplettes gefunden welches mir bei der Installation geholfen hat.
Hier nun eine Checkliste wie es bei mir funktioniert hat:

Was braucht man bevor man loslegt ?
- CD mit RT4 Firmware. Diese muss die aktuell laufende Version der HDD im Fahrzeug sein ! (Bei mir SW 8.31)
- SSD mit ca. 30GB und IDE Interface (Ich habe mich für die Transcend TS32GPSD330 entschieden ; €50,-)
- Ein USB zu IDE Kabel oder ein altes externes 2,5 Zoll Gehäuse mit IDE Anschluss (kein SATA)
- Torx 10 zum Ausbau des RT4
- Torx T9 für den Deckel des RT4
- Flachen Seitenschneider
- PC mit irgendeinem Windows drauf und freien USB Slot

1) Ausbau der HDD
- Zündung aus und warten bis das RT4 keine Geräusche mehr von sich gibt; keine Türen schliessen oder öffnen.
Damit ist das RT4 stromlos. (Alternativ kann man sicher auch die Batterie abklemmen)
- Rt4 mit Torx10 Schlüssel durch die zwei Löcher an der Front lösen und vorsichtg raushebeln
- Stromstecker mit Hebel lösen und abziehen. Restliche Kabel (Bildschirm, Antennen, USB) habe ich dran gelassen
- Schrauben des RT4 Deckels mit T9 entfernen (Hinten Lang selbstschneidend, Vorn metrisch)
- Deckel raushebeln (Vorn anheben und abziehen)
- Dann seht ihr direkt auf das CD Laufwerk welches sich einfach anheben lässt. Das CD Laufwerk nach hinten klappen.
Aufpassen, dass das Flexband nicht knickt ! (Ist lang genug)
- Ihr habt dann freien Blick auf die Festplatte welche nur in der Mulde liegt und mit Plastiknasen gehalten wird.
Die HDD vorne vorsichtig anheben, so dass sie nach vorn gezogen werden kann.
Nicht mit Gewalt ziehen denn der Konnektor hinten ist nur an einem Flexband fest das nicht sehr stabil wirkt.
Die HDD vom Stecker abziehen; ggf. vorsichtig mit einem Schraubenzieher raushebeln.

2) Sicherung der HDD Daten
- Die HDD am PC anschliessen. Es werden von Windoof 4 Laufwerke erkannt. Laufwerksgröße bitte notieren.
- Den Inhalt jedes Laufwerks in einen Ordner auf den PC kopieren (Einfaches Copy & Paste)

3) Vorbereiten der SSD
- Die SSD sollte keine Ordnerstruktur haben. Falls ihr sie doch schon formatiert habt, könnt ihr durch Löschen der Partition(en) einen jungfräulichen Zustand wieder herstellen.
- Die Original HDD läuft im "Slave" Modus und der Flexprint des RT4 hat dafür die beiden äusseren Pins bereits gebrückt.
Die Transcend SSD entspricht leider nicht dem üblichen Standard für die Jumper Settings (Master/Slave/CSL) und benötigt einen Jumper ganz aussen um als Master zu laufen.
Wenn der Jumper nun entfernt wird um die Platte zu intallieren, brückt der RT4 Stecker wieder und die Platte bootet als Master nicht (RT4 Master ist die CD)
Daher: Seitenschneider nehmen und die beiden äusseren Pins an der SSD abknipsen !
- SSD nun in das RT4 setzen und das CD Laufwerk wieder in Position bringen.
- RT4 Stromstecker wieder ran und einschalten. Nach einiger Zeit kommt die Aufforderung eine Update CD einzulegen.
- CD mit Firmware einlegen und warten (CD läuft an und die SSD wird vom System partitioniert, Dann startet das System neu. Dauert nur ca. 30 Sekunden. Also keine Gefahr für den Energiesparmodus.
- CD auswerfen
- Ausbau der SSD Analog zu 1)

4) Daten auf SSD bringen
- SSD an den PC anschliessen. Es werden von Windoof nun wieder 4 Laufwerke erkannt. Falls diese als nicht formatiert angemahnt werden, einfach mit Windoof Boardmitteln auf FAT32 formatieren (Fat 16 nicht nötig!).
- SSD Alignment checken und korrigieren (WICHTIG: denn das RT4 lässt 3 der 4 Laufwerke nicht aligned !)
Mehr dazu unter:
http://explipedia.de/ssd-alignment-nachtraglich-andern-video/
- Zuvor gesicherte Daten vom PC wieder 1:1 auf das entsprechende SSD Laufwerk kopieren (zuvor notierte Laufwerksgröße garantiert die richtige Zuordnung).

5) Abschluss:
- SSD wieder ins RT4 einbauen, das Gerät wieder komplettieren und in die Mittelkonsole einsetzen.
- RT4 einschalten und sich über die Geschwindigkeit freuen.

Das war's. Hoffe der eine oder andere kann damit was anfangen.

Frohes Schweben
Hida0815

 

Link zum Beitrag


Link zum Beitrag
Auf anderen Seiten teilen
koreshuk

Good day to all
I'have just finished reading this topic however there is no answer on my situation. I'm trying to change my Toshiba HDD to Kingspec SSD. Side pins on SSD drive are deleted and system image from toshiba is ready but... When SSD is in RT4 it shows Citroen sign and restarts after 15-20 seconds. It happens as a look. Tried to wait and press 2 grey buttons at the bottom of RT4 base however nothing hepls. Result is still the same - ctiroen sign and loop restart.

Any thoughts why it happens? ta42QsdlkO0.jpg

Link zum Beitrag


Link zum Beitrag
Auf anderen Seiten teilen
accmzöbix

Wich type of Citroen?

Did you start the  engine  or only ignition , when  the SSD started running?, may be , the  energy saving mode switched the  ssd off.

Link zum Beitrag


Link zum Beitrag
Auf anderen Seiten teilen
koreshuk

Citroen C5 2.2HDi 2012

This is definitely not Economy Mode. EM happens after 30min approximately when engine is off. Engine was off right before swapping HDD and SSD.

 I think I tried everything and so many times so I'm confused.

I will try tomorrow to be sure:  ignition on (without starting engine) and wait for a result.

Link zum Beitrag


Link zum Beitrag
Auf anderen Seiten teilen
Chaotec

Did you copy the old data from the hdd to the sdd? Maybe you can try to blank the sdd and create the needed partitions with an update CD.

Link zum Beitrag


Link zum Beitrag
Auf anderen Seiten teilen
-Hida0815

Just guessing, but: The Kingspec SSD requires a bridge between Pin 2 and 4 to run in "Slave Mode". No Bridge and cutting Pin 1&2 would force it to run as "Cable Select" Mode. A mode which is not supported by the RT4.

Try to connect Pin 2 and 4 before you assemble the SSD into the RT4 and see if it helps.

Link zum Beitrag


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an um zu kommentieren

Du musst ein Benutzerkonto haben um einen Kommentar hinterlassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Geht einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden