C5_hdi

Diagbox für PSA Fahrzeuge bis 2013 verwendbar?

Recommended Posts

C5_hdi

Hallo liebe Community,

die Diagbox soll ja bis Fahrzeuge bis Modelljahr 2013 verwendbar sein. Aber warum funktioniert diese nicht mehr danach bzw. woran liegt dies? Bei den neueren Fahrzeug soll man ja eine Onlineverbindung zu Citroen brauchen um bestimmte Sachen codieren zu können. Gibts da evtl. nochmals ein Update.

Achtung. Ich rede von den China Teilen...die bei Ebay unterwegs sind.

Kann mich da jemand auf den aktuellen Stand bringen, danke!

Gruß

Matthias

Share this post


Link to post
Share on other sites
cit-rotti

Hallo,

das Thema ist sehr komplex - Suchfunktion benutzen.

Grundsätzlich gilt: Mit der derzeit verfügbaren Software können Citroen/Peugeot Fahrzeuge diagnostiziert werden, deren Steuergerätekonfiguration vor Herbst 2016 liegen.

Eigentlich sollte  bei der DB V07... nur soweit upgedatet werden, wie es das oder die Fahrzeuge erfordern.

Unabhängig von der Klon-Problematik - manche können mehr - manche weniger - entsprechen Updates bis V07.57 (Stand ca. Mitte 2015) der Originalsoftware, welche bis V07.65 ging - danach kam die V08...

Höhere Updates -  ab V07.66 bis 7.83 gab es ja bei PSA in Wirklichkeit nie.

Nachdem die China-Spezialisten aber keinen Patch für die V08 Software freigeben oder nicht haben oder ihre Klons mit der höherwertigen Firmware nicht arbeiten können, haben Diagnose Spezialisten die Updates V08.01 - V08.19 unter der V07.66 - V07.83 abgeändert.

Gruß Wolfgang

Share this post


Link to post
Share on other sites
tknieper

Hallo,

nachdem ich schon viel bei euch im Forum geschaut habe, hätte ich da ein paar Fragen zur Diagbox.

Ich fahre einen Peugeot 207 SW von 2013, bei dem ich gerne den Tempomat codieren möchte, wozu ich mir einen China-Klon besorgt habe.

Nach Umwegen über eine Virtual Machine mit schlechter Leistung und daher abgebrochener Installation sowie dem Versuch mit einer externen startfähigen Festplatte (die mit 32bit-Systemen und neueren Prozessoren/UEFIS nicht funktioniert, habe ich einfach mal probiert, Diagbox auf Windows 10 64 bit zu installieren, was auch einwandfrei geklappt hat (im zweiten Versuch, da in der pdf-Anleitung nicht darauf hingewiesen wurde, die Datei appdiag.sys während des Updates zu verschieben).

Das Programm fährt sauber hoch, Alles scheint sauber zu funktionieren. Nur egal ob ich den USB2.0 oder 3.0-Port nutze, ich bekomme keine Verbindung zum Fahrzeug.

Bei euch habe ich schon mehrfach gelesen, dass PP2000 nicht unter 64bit-Systemen funktioniert. Wird für mein Auto das in Diagbox enthaltene PP2000 verwendet, das nur mit 32 bit läuft?

Gibt es eine Möglichkeit, zu testen, ob mein Interface sauber funktioniert? Vom Benutzen des "Interfacecheckers" wird ja eigentlich durchgängig abgeraten...

Gibt es noch irgendeinen Trick oder 32bit-Treiber, der mein Problem lösen könnte?

 

Gruß Thomas

Edited by tknieper

Share this post


Link to post
Share on other sites
Ronald
vor einer Stunde schrieb tknieper:

Vom Benutzen des "Interfacecheckers" wird ja eigentlich durchgängig abgeraten...

:confused: Was soll passieren?

Unbenannt.PNG.ace1cfc4ab2bcb6f5233ab634086e45e.PNG

Peugeot 2013 funktioniert nicht mit der Diagbox direkt?

Unbenannt.PNG.ae2ab99dcab2d4d5d55fa9f34303efaf.PNG

Ronald

 

Share this post


Link to post
Share on other sites
tknieper

Ist nicht bei der Diagbox das PP2000 und Lexia integriert?

Oder werden neuere Fahrzeuge, die nicht PP2000 oder Lexia-fähig sind, mit neuen Programmbausteinen der Diagbox ausgelesen?

Irgendwo stand nämlich, dass es bei älteren Fahrzeugen mit Win 10 64 bit Probleme geben kann.

Fällt da mein 207 Facelift drunter, wenn er 2013 gebaut wurde, aber vom Typ her aus 2009 ist?

 

 

So, habe gerade den Interface-Checker mal drüber laufen lassen, Ergebnis siehe Bild.

Die Seriennummer scheint unbekannt zu sein, wobei ich nicht weiss, ob das ggf. an der Klon-Version liegt.

Er scheint aber keine Version der Datei von Appli.com zu haben.

Checker.JPG.01999697ec4d7947b9f39f0655915144.JPG

 

Kann ich da einfach die neueste Version aus den Installationsdateien (siehe Bild) nehmen und die Sache ist erledigt, weil der Fehler am Interface lag (habe bis Version 7.57 geupdated, weil diese Version am stabilsten laufen soll und für mein Fahrzeug ausreichend ist)?

Auswahl.JPG.c4d309eb1d99256de69b25eebc084ed8.JPG

 

Edited by tknieper

Share this post


Link to post
Share on other sites
Ronald

Die Diagbox überprüft die Firmware des Adapers und "flasht" diesen mit der Passenden. Bei deinem Adapter ist V3.3.2 installiert. Sollte passen. Wenn Peugeot und 207 ausgewählt wurde, wird dann die FIN ausgelesen?

vor 20 Minuten schrieb tknieper:

werden neuere Fahrzeuge, die nicht PP2000 oder Lexia-fähig sind, mit neuen Programmbausteinen der Diagbox ausgelesen?

Ich meine ja. Wenn noch PP2000 nötig ist, wechselt die Diagbox das Programm. Dann geht es aber nur mit 32-bit Windows weiter.

Ronald

Edited by Ronald

Share this post


Link to post
Share on other sites
tknieper

Nein, er baut gar keine Verbindung auf und findet daher auch die FIN nicht.

 

Kann der Fehler daran liegen, dass eigentlich PP200 benötigt werden würde?

Oder bin ich mit Baujahr 2013 schon "modern" genug?

Share this post


Link to post
Share on other sites
Ronald

Bei Citroen war die Umstellung von Lexia bei C5/C6. Peugeot wird auch nicht später "dran" gewesen und der 207 sollte somit modern genug sein.

Ronald

Share this post


Link to post
Share on other sites
tknieper

Und kann es helfen, wenn ich manuell die Datei aufspiele und das nicht von Diagbox machen lasse?

Bzw. steht bei euch auch, dass die Seriennummer des Interface unbekannt ist?

 

Denkt ihr der Fehler liegt am Interface?

 

Und wenn der Wechsel von C5 zu C6 war, könnte er bei Peugeot ja auch von 207 nach 208 gewesen sein, da der 207 doch schon aus 2006 ist und vielleicht beim Facelift nichts angepasst wurde... Der C6 wurde zwar 2005 eingeführt, der C5 aber noch bis 2017 weitergebaut...

Share this post


Link to post
Share on other sites
Ronald
vor 1 Stunde schrieb tknieper:

steht bei euch auch, dass die Seriennummer des Interface unbekannt ist? 

Ja, kein anderer Peugeot/Citroen in der Nähe?

Ronald

Share this post


Link to post
Share on other sites
tknieper

Leider nein, bin der einige PSA-Konzern-Fahrer im Bekanntenkreis.

Und ich meinte ja nicht die Seriennummer des Fahrzeugs sondern die vom Interface. Es seie denn du meinst, ich solle einfach mal einen anderen Wagen anstecken, um zu testen, ob er dann die richtige Datei aufs Interface spielt. Aber die Seriennummer des Interface bleibt dann immer noch unbekannt.

Was ich nicht verstehe ist, wenn es eine automatische Erkennung der FIN gibt, weiss Diagbox doch noch gar nicht, welche Datei es auf das Interface aufspielen muss. Der wird doch wohl nicht so lange durchprobieren, bis es irgendwann mal passt.

 

Daher dachte ich, es hilft, vorher mal die richtige bzw. neueste Datei aufs Interface zu spielen, damit das Auslesen funktioniert...

Share this post


Link to post
Share on other sites
Ronald

Der Adapter hat von der Diagbox V7.57 die passende Firmware V4.3.2 erhalten. Erste Zeile vom Checker, passt. Die Seriennummer des Adapters erkennt mein Checker auch nicht. Es gibt Adapter da stehen nur yyyyy

neu.PNG.3bab40963ff7a3ff5f10e5c90bffce9d.PNG

Die FIN vom Fahrzeug sollte der Adapter erkennen, Zündung an und ggf. entsprechende Sicherung i.O.?

Ronald

Edited by Ronald

Share this post


Link to post
Share on other sites
tknieper

Ja, die Zündung war an und der Energiesparmodus nicht aktiv, wobei das keine Rolle spielen dürfte mit dem Energiesparmodus.

Am Auto funktioniert aktuell Alles, nur die Klimaautomatik kühlt nicht richtig, deshalb wollte ich ja auslesen (und den Tempomat codieren). 

Am Anfang kam ich einmal in das Reparaturmenü, wo er dann Steuergerät nach Steuergerät nicht gefunden hat, also müssten alle Sicherungen defekt sein, oder gibt es eine spezielle Sicherung, die ggf. defekt sein könnte? Vom BSI oder so, aber dann würde doch das Auto gar nicht funktionieren, oder?

Zur Firmware, dann hat Diagbox also die richtige Firmware installiert, was schonmal gut ist. Nur die Flash-App und das Appli-File sollte er noch draufmachen, oder wie verstehe ich das richtig? Und wenn die Firmware von 2014 ist, sollte der auch mein 2013er Modell erkennen, oder?

 

 

Edited by tknieper

Share this post


Link to post
Share on other sites
Ronald

Firmware ist OK, da muss nix manuell geflasht werden. Ich denke der Adapter taugt nix. Schau mal rein, ob Du die 7 Optokoppler siehst. Oft sind da nur 2.

Unbenannt.PNG.7e41b0351542254d46f326652376cc3f.PNG

Ronald

Share this post


Link to post
Share on other sites
tknieper

Na dann werde ich es wohl mal aufschrauben. Kann doch nicht so schwer sein, einen ordentlichen Adapter zu haben.

Weisst du, bei welchen Ebay-Verkäufern es die guten, und bei welchen es die schlechten Adapter gibt? Und was macht eigentlich so ein Optokoppler :-)

Share this post


Link to post
Share on other sites
Ronald
vor 2 Stunden schrieb tknieper:

Weisst du, bei welchen Ebay-Verkäufern es die guten, und bei welchen es die schlechten Adapter gibt? Und was macht eigentlich so ein Optokoppler :-)

Pauschal kommen die "guten" aus GB und kosten ab 120 € + Versand, alles darunter hat falsche, gefälschte oder zuwenig Optokoppler. Lesen muss man die Beschreibung trotzdem.

 

Zitat

 

Ein Optokoppler ist ein Bauelement der Optoelektronik und dient zur Übertragung eines Signals zwischen zwei galvanisch getrennten Stromkreisen. Er besteht üblicherweise aus einer Leuchtdiode (LED) oder Laserdiode (LD) als optischem Sender und einer Photodiode oder einem Fototransistor als optischem Empfänger. Das Sende- und das Empfängerbauelement sind untereinander optisch gekoppelt in einem von außen lichtundurchlässigen Gehäuse untergebracht.

Mit Optokopplern können sowohl digitale, als auch analoge Signale übertragen werden. Von Optokopplern zu unterscheiden sind Halbleiterrelais, welche als Bauteil zur galvanischen Trennung einen Optokoppler enthalten können und primär in der elektrischen Energietechnik eingesetzt werden. Auch sogenannte Gabelkoppler und Lichtschranken unterscheiden sich von Optokopplern, da sie über kein von außen lichtundurchlässiges Gehäuse verfügen und einen anderen Anwendungszweck haben.

 

https://de.wikipedia.org/wiki/Optokoppler

Ronald

Share this post


Link to post
Share on other sites
tknieper

Ich werds mal bei Ebay reklamieren, egal was es kostet, funktionieren muss es. Und sonst sollen sie ihren Krempel zurücknehmen und ich bestelle mir etwas Besseres aus UK.

Share this post


Link to post
Share on other sites
pargelenis
Am ‎02‎.‎07‎.‎2018 um 11:48 schrieb tknieper:

Ich werds mal bei Ebay reklamieren, egal was es kostet, funktionieren muss es. Und sonst sollen sie ihren Krempel zurücknehmen und ich bestelle mir etwas Besseres aus UK.

Wie ist der letzte Stand ?

Funktioniert Deine Diagbox jetzt ?

Wenn, ja wie hast du es hinbekommen ?

Oder hast du was neues gekauft ?

Share this post


Link to post
Share on other sites
iseathome

Hallo, hat jemand aktuell einen funktionierenden China-Kracher gekauft? Ich möchte einen C5 II und einen 307cc auslesen und musste leider gerade ein unbrauchbares Set zurück schicken.

Gruß Friedhelm

Share this post


Link to post
Share on other sites
Samy 37

Hallo Leute, 

Bin neu hier hoffe ihr nimmt mich im. Club auf 

Habe Gestern Diagbox 7.83 aus ebay bekommen 105 € bezahlt 

Also alles dabei Kabel ect. CD usw

Bin am verzweifeln ich bekomme es einfach ab der Aktivierung nicht hin weiter zu kommen 

Code 1234567 

Aber immer Fehler 0

Anleitung ist eigentlich gut beschrieben aber ich Weiss nicht wo der Fehler liegt 

Deamon tool usw 

Software nicht über China sondern hier aus Deutschland Verkäufer auch sehr seriös 

Laptop Win 7 32 bit 

Was mache ich falsch bitte ich brauche eure Hilfe ich Weiss auch nicht was ich falsch mache 

 

Meine Name ist Samy 

Share this post


Link to post
Share on other sites
cit-rotti

Hallo Samy,

der Fehler "0" deutet auf einen nicht funktionierenden LAN Treiber hin oder auf ein fehlendes Begleitprogramm.

Der Code muss immer 7-stellig sein - wobei die meisten "scary01" benutzen.

Wenn notwendig biete ich Dir einen Telefonkontakt an.

Gruß Wolfgang

 

 

Share this post


Link to post
Share on other sites
Samy 37

Hallo Wolfgang 

Danke für deine schnelle Antwort 

Echt super 

Ja sehr gerne 

Share this post


Link to post
Share on other sites
Lichtspruch

Zur Orientierung: mein Chinateil ist von eobdtool.co.uk.

Lexia 345-12 (?)  habe auf einem WIN XP Home SP3 32 Bit Rechner installiert und, viel wichtiger, erfolgreich aktiviert.

Auf einem anderen Rechner, ebenfalls mit  WIN XP Home SP3 32 Bit, läuft DiagBox 07.02. Ich wollte höher updaten, aber es kommt jenseits von 07.62 zu  Problemen, meistens lässt sich das Programm überhaupt nicht mehr starten, alle Müh' war dann für die Katz'. Alles noch mal auf Anfang, insgesamt sechs oder sieben Mal!

Meine Fragen zur DiagBox-Software:

  1. Wann wurden die einzelnen Software-Releases von PSA offiziell veröffentlicht? - Zufällig weiß ich, dass die Version 06.11 im Sommer 2010 aktueller Stand war. Aber das ist auch schon alles. Mich interessieren die Veröffentlichungszeitpunkte der Versionen 07.02, 07.57, 07.58, 07.62, 07.66, 07.74, 07.76, 07.82 und 07.83.
  2. Ab welcher Version stellt DIagbox offline Reparaturanleitungen und Schaltpläne zur Verfügung? Oder muss man dazu online gehen, was man eigentlich nicht machen sollte? Wenn ich eine Dokumentation zu einem Fahrzeug anfordere, stellt DiagBox richtigerweise fest, dass weder eine Verbindung zum Internet noch zu PSA besteht. Da ich mit meinem Rechner natürlich nicht online gehe, wird im letzten Schritt verkündet, dann sei eine Anzeige der angeforderten Dokumente nicht möglich - oder so ähnlich. Oder habe ich bei der Installation etwas falsch gemacht?
  3. Kann man eine China-DIagBox in Verbindung mit offiziellen Bezahl-Dienstleistungen der PSA Service Box (früher Citroen Service Portal) nutzen? Da gibt es z. B. Bezahlabos auf Zeitbasis (Stunden, Tage, Wochen, Jahre) für Online-gestützte Fehleranalyse usw.
Edited by Lichtspruch

Share this post


Link to post
Share on other sites
Walter01
Am 8.4.2019 um 21:18 schrieb Lichtspruch:
  1. Ab welcher Version stellt DIagbox offline Reparaturanleitungen und Schaltpläne zur Verfügung? Oder muss man dazu online gehen, was man eigentlich nicht machen sollte? Wenn ich eine Dokumentation zu einem Fahrzeug anfordere, stellt DiagBox richtigerweise fest, dass weder eine Verbindung zum Internet noch zu PSA besteht. Da ich mit meinem Rechner natürlich nicht online gehe, wird im letzten Schritt verkündet, dann sei eine Anzeige der angeforderten Dokumente nicht möglich - oder so ähnlich. Oder habe ich bei der Installation etwas falsch gemacht

Seltsamerweise kann ich die Zahl Eins nicht wegeditieren. :mellow:

Anyway. Repanleitungen und Schaltpläne stellt Diagbox nicht zur Verfügung. Dazu benötigt man DocBackup und Sedre.

Über Vers. 7.62 kam ich auch nie. Ab 7.66 verlangt es eine Aktivierung.

Edited by Walter01

Share this post


Link to post
Share on other sites
Ronald

Ich habe ohne Probleme 7.83 installieren können. Es gab nur bei V7.82 den Sprachwechsel von Deutsch auf Englisch, der nur über Umwege rückgängig gemacht werden konnte:

Zitat

 

Der Typ der die Software Diagbox "geknackt" und der Allgemeinheit zugänglich gemacht hat, ist "scary" bzw. "scarymistake". Der 2. Typ ist " Maîtresox". Dieser hat sich später um die Updates gekümmert. Speziell um die Updates ab 7.66. Erkennt man an den Installations-Passwörtern: scary01 bzw. maitresox01

Zitat

ab Diagbox V7.66 -> Adapter FW V4.3.4 nur noch mit der  "Maîtresox-Anpassung" der Diagbox-Software an die Firmware V4.3.3 nutzbar, da die nachgebauten Chips nicht mit V4.34 arbeiten

D.h. die Diagbox V7.66 benötigt auf dem Adapter FW4.3.4, aber der China-Adapter kann damit nicht arbeiten, deshalb wurden die Updates so modifiziert, dass nicht FW4.3.4 geflasht wird, sondern nur FW4.3.3. (Deshalb vermutlich auch die doppelte "Zählung" der Versionen im changelog.)

 

https://www.andre-citroen-club.de/forums/topic/125806-gibt-es-einen-lexia-klon-diagnose-für-einen-c3-ii/?do=findComment&comment=1506919

 

Ronald

Edited by Ronald

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.