Jump to content
Sign in to follow this  
Graue Sänfte

Diagbox - Fragen

Recommended Posts

Graue Sänfte

Hallo,

ich habe mich hier angemeldet, weil ich mein Fahrzeug mit der Diagbox auslesen möchte. 

Dazu hatte ich mir bereits 2x in der Bucht einen China-Clon bestellt. Leider ließ sich jeweils die Software nicht installieren, da nicht alle Daten auf der CD vorhanden waren. Aufspielen wollte ich die Software auf ein Notebook mit frisch installiertem Win XP SP3 und ohne Internetzugang, Firewall deaktiviert.

Da ich nun schon 2x ins Klo gegriffen habe mit dem Software-Lieferanten möchte ich mal hier in die Runde fragen, wo Ihr den Clon bestellt habt und worauf ich dabei achten soll.

 

Danke schon mal im voraus für Antworten und Tips!

Share this post


Link to post
Share on other sites
Ronald

Die Software habe ich von hier

Da gibt es eine Liste mit Download-Servern für die Win XP und die Virtual Box Version.

Share this post


Link to post
Share on other sites
cit-rotti
vor 2 Stunden schrieb Graue Sänfte:

Leider ließ sich jeweils die Software nicht installieren, da nicht alle Daten auf der CD vorhanden waren.

...sofern es nur an der mangelhaften Software liegt und die Hardware (VCI mit Zubehör) in Ordnung ist, lässt sich dieses Problem lösen (ISO etc.).

 

vor 2 Stunden schrieb Graue Sänfte:

und ohne Internetzugang

...das Internet muss nicht angeschlossen sein - aber der LAN-Treiber sehr wohl funktionieren, weil darüber der Aktivierung Zugang erfolgt.

 

vor 2 Stunden schrieb Graue Sänfte:

frisch installiertem Win XP SP3

Xp ist grundsätzlich bis 7.82 in Ordnung - allerdings werden auch noch andere Zusatzprogramme benötigt - diese sind z.T. abhängig von den Updates.

 

vor 2 Stunden schrieb Graue Sänfte:

Firewall deaktiviert

der Firewall muss bei der DB nicht deaktiviert werden; es ist nur erforderlich bei den Meldungen "zulassen" zu bestätigen. Ein Anti-Viren-Programm sollte nicht genutzt werden oder muss vor der Installation und Nutzung deaktiviert oder angepasst werden. Nachdem Du vermutlich den Laptop - idealer Weise -  ausschließlich für Diagnosezwecke nutzt erübrigt sich Anti-Vir.

 

vor 3 Stunden schrieb Graue Sänfte:

mein Fahrzeug mit der Diagbox auslesen

..wenn Du uns mitteilst, welche Fahrzeuge mit Baujahr diagnostiziert werden sollen, dann gibt es evtl. auch Infos über sinnvolle Software-Versionen - mehr ist manchmal weniger.

Share this post


Link to post
Share on other sites
Graue Sänfte

Uii, eine Menge Infos innerhalb so kurzer Zeit - finde ich ja klasse! ?

Also mein Fahrzeug ist ein C5 Tourer 2,0 HDI FAP, Bj. 2015. Außerdem muß sich noch ein C4 Coupe, Bj. 2009 auslesen lassen.

Bei der ersten Software-CD wurde zwar die Viruelle Box installiert, aber bei der Installation von Diagbox erschien dann eine Fehlermeldung, daß irgendeine Datei fehlerhaft ist und nicht installiert werden kann - ich habe es dann auf einem anderen PC versucht, wieder erschien die Fehlermeldung. Beim zweiten von einem anderen Anbieter gelieferten Diagbox-Set war es noch nicht mal möglich, die Virtual Box zu installieren. 

Welche Zusatzprogramme und Treiber für Win XP brauche ich denn, damit Diagbox läuft?

Ich habe eben in dem von Ronald verlinkten Forum gelesen, aber so richtig schlau geworden bin ich daraus nicht, was den Bezug der Software betrifft. Kann man die Diagbox-Software einfach so herunterladen? Und wie installiert man die dann? Auf CD brennen oder geht auch ein Stick? Außerdem frage ich mich, woher ich die passenden Kabel bekomme. Worauf muß ich dabei achten?

Tut mir leid, daß ich hier so viele blöde Fragen stelle...

Share this post


Link to post
Share on other sites
Ronald
vor 22 Minuten schrieb Graue Sänfte:

Kann man die Diagbox-Software einfach so herunterladen? Und wie installiert man die dann? Auf CD brennen oder geht auch ein Stick?

Ja, die Daten downloaden. Für die Installation ohne "Virtualisierte Umgebung" benötigt man  noch z.B. "Virtual Clone Drive", um die "Diagbox V7.02 *.iso" dem Rechner als "Installations-Medium" vorzugaukeln und startet dann mit der "setup.exe". Weiß nicht mehr, ob das brennen der iso auf CD und anschließende Installation auch funktioniert.

Mein System damals: Windows 7 Home Premium 64-bit, .NetFramework 3.5 bis 4.7, Internet Explorer 11, Java 9

WLAN aktiv, keine Verbindung

large_V7.83-Daten.PNG.e5795d50045cd505f6

https://www.andre-citroen-club.de/forums/topic/120933-ciii-bluehdi150-lexia-klon-und-diagbox-installieren/?do=findComment&comment=1432881

 

Share this post


Link to post
Share on other sites
cit-rotti

...ergänzend zu dem was Dir Ronald geschrieben hat kommt es immer darauf an auf welchem PC mit welcher Software installiert wird. 

Ideal ist ein eigener Diagnose Laptop mit XP prof. 32 Bit oder WIN 7 32 Bit - dann bei XP Java 7 + Internet-Explorer 8 - erst bei WIN 7 EXplorer 11 und Java 8 - Java 9 gehört eigentlich zu WIN10

Es funktioniert auch auf einem WIN 7 64 Bit -System - allerdings können dann ältere PSA Fahrzeuge nicht diagnostiziert werden.

Natürlich besteht auch die Möglichkeit auf VM zu installieren - mir ist es zu umständlich und oft fehlerbehaftet. Bis alles hochgefahren ist bin ich mit der Diagnose schon fertig. Mein alter T61 mit XP startet das DB-Programm in ca. 10-15 Sekunden.....

Für Deine Fahrzeuge benötigst Du in jedem Fall V07.57 (geht bis Mitte 2015) - ausprobieren und wenn es nicht reicht weiter updaten. Bei diesen Update wird allerdings VC++ 2008 32 Bit und höher benötigt, weil sonst dll fehlen.

Höher als 7.82 (=8.18 bis ca. Mitte 2016)) - theoretisch bis 8.55 möglich (bei VM gibt es oft Probleme ab 7.83) - erfordert WIN 7 32 Bit und macht kaum einen Sinn, weil darin nur APP Update für ältere Modelle verarbeitet wurden und somit für die DB sich nichts ändern. Ab irgend einem Update muss dann auch die Sprache manuell umgestellt werden.

Sofern Du später mal neuere Kisten hast und auf die aktuelle Software umsteigen musst (derzeit so 9.68) benötigst Du - wie Citroen auch - WIN 7 32 Bit und VC++/32Bit bis 2005. VM mit originaler Software nicht aktivierbar. Und wenn Du höher updatest sollst Du die Firmware nicht berühren, weil dann das VCI nicht mehr mit der höheren V09.. arbeitet - es bleibt dann an die Aktivierung der V07 gebunden.

Edited by cit-rotti

Share this post


Link to post
Share on other sites
Ronald
vor 33 Minuten schrieb cit-rotti:

V07.57 (geht bis Mitte 2015)

Keine Ahnung wie ich es "damals" geschafft habe bis V7.83 zu kommen, heutzutage war stets bei V7.57 Schluss, da dann die Registrierung verloren ging.

Das ist die Installation von V7.01 inkl. Update V7.02 und das "große Update" V7.01 auf V7.57. Die Liste oben enthält das Update noch nicht.

large.Unbenannt.JPG.68ddd9d5b39828d5360fcde2b2a74a3a.JPG

Zitat

 

Ich kann das mittlerweile im Schlaf. Vermutlich klappt es deshalb bei Win10 auch nicht bis V7.83 ;), sondern nur bis V7.57

Mein Fazit ist: ohne Probleme  funktioniert bei Win 10 32-bit 1909 und 64 bit 1909 die "normale" Installation der Diagbox V7.57 (V7.01/ V7.02 -> V7.57). Bei 64-bit natürlich ohne Lexia bzw. P2000

  • .Net-Framework 3.5 aktivieren und 4.6 deaktivieren (scheint aber nicht nötig zu sein, denn 4.6 ist abwärtskompatibel)
  • WLAN auschalten, Verbindung trennen, kein Netzwerkkabel angeschlossen
  • ISO mit Virtual Clone Drive als Laufwerk "erzeugen"
  • Defender/ Virenprogramm ausschalten oder die gesperrte Datei ( unerlaubter Remotezugriff) wieder freigeben, wenn man es vergessen hat
  • setup/ install starten
  • alle Firewallmeldungen mit "zulassen" bestätigen
  • manuelle Aktivierung durchführen: XX beibehalten, scary01 eintragen, ist egal
  • keine "Aktualisierungen" suche, niemals!
  • PARAMETER bei * ausfüllen
  • V7.01 beenden, Neustart
  • Diagbox V7.01 starten -> Update auf V7.02 Firewallmeldung wieder zulassen, Treiberinstallation Actia und ? bestätigen
  • V7.02 beenden, Neustart
  • Update V7.XX -> V7.57 starten , Passwort "scary01"->Neustart
  • Diagbox starten, V7.57 installiert sich -> fertig :)

Ab hier ist bei mir Schluss, denn der Zugriff auf die Fahrzeugdatenbank ist ab Update V7.58  nicht mehr möglich. Nun ist es auch egal, ob die Aktivierung ab V7.74 misslingt.

Wie gesagt, ich habe noch eine funktionierende Diagbox V7.83 auf einem lahmen aber stylishen Win7-Netbook. (Celeron 743 1.3 Ghz, 120 GB SSD, 4 GB). Win10 war nur ein Nice-to-have, da wesentlich schneller.

 

https://www.andre-citroen-club.de/forums/topic/120933-ciii-bluehdi150-lexia-klon-und-diagbox-installieren/?do=findComment&comment=1597692

Mit dem PSA Interface Checker kann man zuvor den Adapter auslesen und schauen welche Firmware drauf ist:

YYYYYY ist wohl nicht so toll.

large.Unbenannt.PNG.eaf2b911289e3600dec1b79168973bff.PNGlarge_neu.PNG.694c9e59f15138937b85685b8aae7e15.PNG

und dann gibt es noch das Thema light und full-Chip-Adapter. D.h. 7 Optokoppler oder nur 1 -2 ?

large.IMG_0185.JPG.6bfd74a0838209094997ed1ed94316c6.JPGlarge.CIMG0216.JPG.9721f5ee4252e1a103d6b3426cfa9bb9.JPG

 

Share this post


Link to post
Share on other sites
cit-rotti

Ronald ,

ja WIN10 1909 macht anscheinend bei der DB - auch bei der Original-Version - vielen Probleme - 1903 soll gefügiger sein.

Ideal ist und bleibt WIN 7 32 Bit oder für die DB bis 7.82 XP prof.

Der Defender von WIN 10/1909 kann wahrscheinlich nur zum Schweigen gebracht werden, wenn er nicht nur deaktiviert, sondern völlig entfernt wird (zurück geht dann nicht mehr).

Die DB 7.02 und das Update 7.xx-7.57 sollten von scary sein.
Die weiteren Update bis 7.82 von maitresox. Simple ab 7.83 würde ich mir sparen.
Firmware 4.3.2 sollte nicht angetastet werden. 

An sich installiert sich die DB auch bei 64-Bit Systemen im 32-Bit Programmteil (586); deshalb müssen VC++ auch als 32 Bit versionen installiert sein. 

Wichtig: Keine DB Version verträgt sich mit einer anderen d.h. vor einer Neuinstallation vollständig entfernen.

Bei XP genügt VC++ 2008 - bei WIN 10 denke ich alle VC++.
Java 9 ist evtl. nicht geeignet - bei XP Java 7 - bei WIN 7 Java 8.

In den VC++ finden sich die erforderlichen dll - probiert werden könnte auch AIO Runtime 2.4.9 zu installieren.

Bislang hatte ich keine Installationsprobleme bis 7.82 sowohl auf XP prof wie auch auf WIN 7 32 Bit.
WIN 10  und VM spare ich mir - weil ich kein PC-Spezi bin.

Ich kopiere Dir mal einen guten youtube Link und meine Vorgehensweise - wahrscheinlich funktionieren andere auch.

https://www.youtube.com/watch?v=wJJdj3Qspkk

1.    Jedes Update einzeln ausführen und beenden

Neustart nicht erforderlich (Administratorrechte erforderlich) und Du musst wirklich der Chef sein - nicht nur ein Benutzer mit Chef-Rechten.

 

2.    Sicherungskopie ( bei V07.02 erstellt)nach jedem Update erneuern
(manche Infos erstellen die Sicherungskopie bei V07.57?)

Reihenfolge: Installation Maitresox bis V07.82

A)    Update öffnen und ausführen/starten [Suivant]
am Schluss 2x [Quitter]

Dann Appdiag.sys mit Rechtsklick „kopieren“
Fundstelle: AW-Root/bin/fi/APPDIAG.SYS
mit Rechtsklick „einfügen“ und Austausch bestätigen

C)    Diagbox starten – Update wird installiert – dann DIAGBox schließen.

 

7.57 – 7.58

7.58 – 7.62

7.62- 7.66 (8.02) deutsch

7.66 – 7.74 (8.10) englisch

7.74 – 7.76 (8.12) englisch

7.76 – 7.82 (8.18) englisch (Bei mir: DB englisch/LEXIA französisch/

Edited by cit-rotti
  • Like 1

Share this post


Link to post
Share on other sites
Ronald
vor 54 Minuten schrieb cit-rotti:

Nachtrag Ronald ,

Danke, habe alle Seiten gelesen, aber nur die Vermutung das 2 DLL (libxmlsec-opensslA.dll und LIBSSL.dll) die Ursache sein könnten entdeckt. lm verlinkten Beitrag wurden diese dann erwähnt, aber der umfasst dann 30 Seiten

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...